[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

prio no-transmit



Hi:
I'm reading the archives about CBQ and I have a cuestion that still
remains hard to me:

I'm using the last ds patch (ds-8) over 2.2.14 linux kernel and I'm able
to load the modules sch_cbq, sch_tbf and cls_u32. I'm combining this with
the iproute 2.2.4 RPM from redhat 6.2 and the script /sbin/cbq in the
shapecfg 2.2.12 RPM from the same distribution. After making my cbq-RATE.*
files under /etc/sysconfig/cbq directory:

------------/etc/sysconfig/cbq/cbq-128.tonetworks
DEVICE=eth1,10Mbit,1Mbit
RATE=160Kbit
WEIGHT=128Kbit
PRIO=5
RULE=A.A.A.A/24
------------/etc/sysconfig/cbq/cbq-128.tomainrouter
DEVICE=eth0,10Mbit,1Mbit
RATE=160Kbit
WEIGHT=128Kbit
PRIO=5
RULE=A.A.A.A/24,
------------/etc/sysconfig/cbq/cbq-64.tonetworks
DEVICE=eth1,10Mbit,1Mbit
RATE=96Kbit
WEIGHT=64Kbit
PRIO=5
RULE=B.B.B.B/24
------------/etc/sysconfig/cbq/cbq-64.tomainrouter
DEVICE=eth0,10Mbit,1Mbit
RATE=96Kbit
WEIGHT=64Kbit
PRIO=5
RULE=B.B.B.B/24,
-------------------------------------------------
And after run the "/sbin/cbq start".....

............ I got the following:
------------------------tc class ls dev eth1--------------------
class cbq 11: root rate 10Mbit (bounded,isolated) prio no-transmit
class cbq 11:1 parent 11: rate 10Mbit prio no-transmit
class cbq 11:64 parent 11:1 leaf 802b: rate 96Kbit (bounded) prio 5
class cbq 11:128 parent 11:1 leaf 8029: rate 160Kbit (bounded) prio 5
----------------------------------------------------------------
And I have some drops over my network:
-----------------------tc -s -d qdisc------------------------------
qdisc tbf 802c: dev eth0 rate 96Kbit burst 10Kb/8 mpu 0b lat 508.6ms 
 Sent 2165245 bytes 13835 pkts (dropped 0, overlimits 230) 

 qdisc tbf 802a: dev eth0 rate 160Kbit burst 10Kb/8 mpu 0b lat 305.2ms 
 Sent 16079223 bytes 63740 pkts (dropped 4, overlimits 2264) 

 qdisc cbq 10: dev eth0 rate 10Mbit cell 8b (bounded,isolated) prio
no-transmit/8 weight 10Mbit allot 1514b 
level 2 ewma 5 avpkt 1000b maxidle 23us 
 Sent 18744275 bytes 80689 pkts (dropped 4, overlimits 10888) 
  borrowed 0 overactions 0 avgidle 624 undertime 0

 qdisc tbf 802b: dev eth1 rate 96Kbit burst 10Kb/8 mpu 0b lat 508.6ms 
 Sent 5235127 bytes 10745 pkts (dropped 0, overlimits 1370) 

 qdisc tbf 8029: dev eth1 rate 160Kbit burst 10Kb/8 mpu 0b lat 305.2ms 
 Sent 45319292 bytes 84940 pkts (dropped 126, overlimits 20789) 

 qdisc cbq 11: dev eth1 rate 10Mbit cell 8b (bounded,isolated) prio
no-transmit/8 weight 10Mbit allot 1514b 
level 2 ewma 5 avpkt 1000b maxidle 23us 
 Sent 50637397 bytes 97540 pkts (dropped 126, overlimits 151571) 
  borrowed 0 overactions 0 avgidle 624 undertime 0
--------------------------------------------------------------

Using "ping ip" from my main router I get loss from 1-10% of the
packets. The networks are connected like the next scheme:

Internet<-->Main Router<-->(Eth0)Linux+CBQ<-|(Eth1:Network A.A.A.A)
                                            |(Eth1:0<-->Network B.B.B.B)
                                            v
                      Wireless Link A<-->Switch<-->Wireless Link B
                                 |                       |
                                 |                       |
                                 v                       v
			Network A.A.A.A         Network B.B.B.B


Somebody knows about the no-transmit message in the priority field and if
this is related with the drops in my networks?


-- 
Armando Montiel Caba / Gerente de Sistemas  MPSNet / Proyectos LinuxMPSNet
Tel: (525)4-88-65-55 / SkyTel: 5536911 / ICQ:7690611  / amontiel@mpsnet.net.mx
Av. Coyoacan #734 / Col. del Valle / C.P. 03100 / Fax: (525)4-88-65-00